aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-04-12 23:08:13 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-04-12 23:08:13 +0000
commit81efe748e3039a205cf8754d8cdfb415ca030a7d (patch)
tree83438790a7e2af6c8a25a30ef45cec4c8327f7b5 /target/imagebuilder
parentba61fdbb241ca874d69c7ff1d52c4a7ece7f9339 (diff)
downloadmaster-187ad058-81efe748e3039a205cf8754d8cdfb415ca030a7d.tar.gz
master-187ad058-81efe748e3039a205cf8754d8cdfb415ca030a7d.tar.bz2
master-187ad058-81efe748e3039a205cf8754d8cdfb415ca030a7d.zip
[imagebuilder] populate repositories.conf from version.mk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31268 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile3
-rw-r--r--target/imagebuilder/files/repositories.conf4
2 files changed, 4 insertions, 3 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 30083999e4..3d04656250 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -8,6 +8,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/version.mk
override MAKEFLAGS=
@@ -34,7 +35,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
$(TMP_DIR)/.targetinfo \
$(TMP_DIR)/.packageinfo \
$(PKG_BUILD_DIR)/
- $(SED) 's/$$A/$(BOARD)/' $(PKG_BUILD_DIR)/repositories.conf
+ $(VERSION_SED) $(PKG_BUILD_DIR)/repositories.conf
$(CP) $(PACKAGE_DIR) $(PKG_BUILD_DIR)/packages
$(CP) $(STAGING_DIR_HOST)/bin $(PKG_BUILD_DIR)/staging_dir/host/
$(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
diff --git a/target/imagebuilder/files/repositories.conf b/target/imagebuilder/files/repositories.conf
index 4a55adb859..708855eb8c 100644
--- a/target/imagebuilder/files/repositories.conf
+++ b/target/imagebuilder/files/repositories.conf
@@ -1,6 +1,6 @@
## Place your custom repositories here, they must match the architecture and version.
-# src/gz snapshots http://downloads.openwrt.org/snapshots/trunk/$A/packages
-# src custom file:///usr/src/openwrt/bin/$A/packages
+# src/gz %n %U
+# src custom file:///usr/src/openwrt/bin/%T/packages
## This is the local package repository, do not remove!
src imagebuilder file:packages