aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-06 12:31:31 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-06 12:31:31 +0000
commit50bd81d3df1da5fede46e2f62c7cce53065c3ec4 (patch)
treee3b308ed930bad633168f04bd0df6e417e9bb412 /target/imagebuilder
parent07e19452d87a6304a56b9bd069c7e5eebbb5bc68 (diff)
downloadmaster-187ad058-50bd81d3df1da5fede46e2f62c7cce53065c3ec4.tar.gz
master-187ad058-50bd81d3df1da5fede46e2f62c7cce53065c3ec4.tar.bz2
master-187ad058-50bd81d3df1da5fede46e2f62c7cce53065c3ec4.zip
imagebuilder: don't pregenerate package index, strip host binaries
The package index is generated on first use anyway, therefore it makes no sense to continue shipping it. Also sstrip the bundled host binaries when packing the IB to save some additional space. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44293 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index ecb8ac7cf4..a8ff4a3c5a 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -56,8 +56,8 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
find $(PKG_BUILD_DIR) -name CVS -o -name .git -o -name .svn \
| $(XARGS) rm -rf
find $(STAGING_DIR_HOST)/bin -maxdepth 1 -type f -perm -u=x \
- | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin
- $(MAKE) -C $(PKG_BUILD_DIR) package_index
+ | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin/
+ STRIP=sstrip $(SCRIPT_DIR)/rstrip.sh $(PKG_BUILD_DIR)/staging_dir/host/bin/
$(TAR) -cf - -C $(BUILD_DIR) $(IB_NAME) | bzip2 -c > $@
download: