aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-06 00:27:06 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-06 00:27:06 +0000
commit24d181ebd58f675d51d5f081b62808983b8f0146 (patch)
tree0e7cebf2ef36ca1bca502ca97f1b29197fea2716 /target/imagebuilder
parentf154b5d98c1b60452d38a2458e66bd362039bfbe (diff)
downloadmaster-187ad058-24d181ebd58f675d51d5f081b62808983b8f0146.tar.gz
master-187ad058-24d181ebd58f675d51d5f081b62808983b8f0146.tar.bz2
master-187ad058-24d181ebd58f675d51d5f081b62808983b8f0146.zip
imagebuilder: use FreeBSD compatible tar invocation
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44288 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 82fdab40d8..ecb8ac7cf4 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -58,7 +58,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
find $(STAGING_DIR_HOST)/bin -maxdepth 1 -type f -perm -u=x \
| $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin
$(MAKE) -C $(PKG_BUILD_DIR) package_index
- $(TAR) c -C $(BUILD_DIR) $(IB_NAME) | bzip2 -c > $@
+ $(TAR) -cf - -C $(BUILD_DIR) $(IB_NAME) | bzip2 -c > $@
download:
prepare: