aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/files
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2009-07-02 07:24:50 +0000
committerAndy Boyett <agb@openwrt.org>2009-07-02 07:24:50 +0000
commitfbe393f9e8e21ea0ac844251ff609df042521d8e (patch)
tree05c112ae22f4479a0423780f542723ba798fe643 /target/imagebuilder/files
parent48d5c2e8504ae8dad6e4886e7d04bd1a52fd1457 (diff)
downloadmaster-187ad058-fbe393f9e8e21ea0ac844251ff609df042521d8e.tar.gz
master-187ad058-fbe393f9e8e21ea0ac844251ff609df042521d8e.tar.bz2
master-187ad058-fbe393f9e8e21ea0ac844251ff609df042521d8e.zip
[ImageBuilder] fix profile package selection, packages from last parsed profile were accidentally installed
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16653 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder/files')
-rw-r--r--target/imagebuilder/files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index b526925177..c7f43550ab 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -1,6 +1,6 @@
# Makefile for OpenWrt
#
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -81,7 +81,7 @@ $(TOPDIR)/tmp/ipkg.conf: FORCE
@echo 'dest root /' > $@
@echo 'src packages file:$(PACKAGE_DIR)' >> $@
-BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(PACKAGES) $($(PROFILE)_PACKAGES) kernel)
+BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $($(PROFILE)_PACKAGES) kernel)
ifeq ($(KERNEL),2.4)
BUILD_PACKAGES:=$(patsubst base-files,base-files-$(BOARD)-$(KERNEL),$(BUILD_PACKAGES))
else