aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/files
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-22 04:03:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-22 04:03:35 +0000
commitc6d265f356980b1dffc9f1bdb464f5e76f7b714f (patch)
tree0fa77c919e9532a5d33b937a826c3f447660587c /target/imagebuilder/files
parent76ba15fe00dba92f5e415d47c481d28ba7e5e206 (diff)
downloadmaster-187ad058-c6d265f356980b1dffc9f1bdb464f5e76f7b714f.tar.gz
master-187ad058-c6d265f356980b1dffc9f1bdb464f5e76f7b714f.tar.bz2
master-187ad058-c6d265f356980b1dffc9f1bdb464f5e76f7b714f.zip
ignore profiles with custom kernel configs in the image builder itself
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6342 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder/files')
-rw-r--r--target/imagebuilder/files/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index b36e2f2e31..8b386a33c6 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -34,6 +34,7 @@ IPKG:= \
define Profile/Default
ID:=
NAME:=
+ KCONFIG:=
PACKAGES:=
endef
@@ -46,8 +47,10 @@ define AddProfile
endif
$(ID)_NAME:=$(NAME)
$(ID)_PACKAGES:=$(PACKAGES)
- PROFILE_LIST += \
+ ifneq ($(KCONFIG),)
+ PROFILE_LIST += \
echo '$(ID):'; [ -z '$(NAME)' ] || echo ' $(NAME)'; echo ' Packages: $(PACKAGES)';
+ endif
endif
endef