aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/files
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-27 11:22:20 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-27 11:22:20 +0000
commit841bf546abcdc001a5d75e2d3a39b120e516137f (patch)
tree226cccd3d866371495239bf5476f35b3f5a625d2 /target/imagebuilder/files
parentaf3ff424675ac28c33aab4e7317b6f93814461e8 (diff)
downloadmaster-187ad058-841bf546abcdc001a5d75e2d3a39b120e516137f.tar.gz
master-187ad058-841bf546abcdc001a5d75e2d3a39b120e516137f.tar.bz2
master-187ad058-841bf546abcdc001a5d75e2d3a39b120e516137f.zip
IB: use online repositories
Change the IB packaging to only embed libc, kernel and kmod packages by default and generate repositories.conf to refer to the remote package repositories. Introduce a new config option CONFIG_IB_STANDALONE which restores the old behaviour of building self contained IB archives. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45772 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder/files')
-rw-r--r--target/imagebuilder/files/Makefile4
-rw-r--r--target/imagebuilder/files/repositories.conf2
2 files changed, 2 insertions, 4 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index f3bfec1e31..0f0fe42b59 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -107,7 +107,7 @@ _call_image:
$(MAKE) package_index; \
else \
mkdir -p $(TARGET_DIR)/tmp; \
- $(OPKG) update; \
+ $(OPKG) update || true; \
fi
$(MAKE) package_install
ifneq ($(USER_FILES),)
@@ -123,7 +123,7 @@ package_index: FORCE
(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
gzip -9c Packages > Packages.gz \
) >/dev/null 2>/dev/null
- $(OPKG) update
+ $(OPKG) update || true
package_install: FORCE
@echo
diff --git a/target/imagebuilder/files/repositories.conf b/target/imagebuilder/files/repositories.conf
index 708855eb8c..8f1f27fe50 100644
--- a/target/imagebuilder/files/repositories.conf
+++ b/target/imagebuilder/files/repositories.conf
@@ -2,5 +2,3 @@
# src/gz %n %U
# src custom file:///usr/src/openwrt/bin/%T/packages
-## This is the local package repository, do not remove!
-src imagebuilder file:packages