aboutsummaryrefslogtreecommitdiffstats
path: root/target/image/x86
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-08-25 09:28:15 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-08-25 09:28:15 +0000
commitff3c4babd65c0814dcf58ff64aa5bdf317470882 (patch)
treef5d277e8f68a84eebd2790cfa17a6fe311c94dfd /target/image/x86
parentbeef3e3c616acd27a0aa8f8ac54a3488cf2cfc33 (diff)
downloadmaster-187ad058-ff3c4babd65c0814dcf58ff64aa5bdf317470882.tar.gz
master-187ad058-ff3c4babd65c0814dcf58ff64aa5bdf317470882.tar.bz2
master-187ad058-ff3c4babd65c0814dcf58ff64aa5bdf317470882.zip
Override kernel template and output bzImage, not the binary file, closes #676 and #714
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4658 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/image/x86')
-rw-r--r--target/image/x86/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/image/x86/Makefile b/target/image/x86/Makefile
index d9ed294574..919ccbc9fe 100644
--- a/target/image/x86/Makefile
+++ b/target/image/x86/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
define Image/Build
cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
- cp $(KDIR)/vmlinux $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+ cp $(LINUX_DIR)/arch/i386/boot/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
endef
$(eval $(call BuildImage))