aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-08 09:08:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-08 09:08:38 +0000
commite295e9cf7cfbd7f30c932549588867c137c9d103 (patch)
tree463c013e23557a5b9082ada45a3d7b583857450e /target/Makefile
parent767792e7a621d580a23e8ba0df1bf2c1f664f744 (diff)
downloadmaster-187ad058-e295e9cf7cfbd7f30c932549588867c137c9d103.tar.gz
master-187ad058-e295e9cf7cfbd7f30c932549588867c137c9d103.tar.bz2
master-187ad058-e295e9cf7cfbd7f30c932549588867c137c9d103.zip
add some fixes for parallel build (does not work with -j4 yet, but it gets most packages compiled now)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@577 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/Makefile b/target/Makefile
index 6a1bd954a0..437609a28b 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -73,6 +73,7 @@ $(BIN_DIR):
mkdir -p $(BIN_DIR)
$(INSTALL_TARGET_DIRS): lzma-loader-compile
+$(IMAGE_TARGETS): $(patsubst %,%-install,$(TARGET_DIRS))
compile: $(patsubst %,%-compile,$(TARGET_DIRS))
install: utils-install lzma-install $(LINUX_IMAGE) $(patsubst %,%-install,$(TARGET_DIRS)) $(IMAGE_TARGETS)
clean: $(patsubst %,%-clean,$(TARGET_DIRS)) image_clean