aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-02 19:06:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-02 19:06:50 +0000
commitdae7e90107f09031e05500e09a238dc7445d78bf (patch)
tree4d80baf37b57ec311461834e82db4a7053417ca9 /target/Makefile
parent786263062955ddd4591994801a833a2d10cee8b6 (diff)
downloadmaster-187ad058-dae7e90107f09031e05500e09a238dc7445d78bf.tar.gz
master-187ad058-dae7e90107f09031e05500e09a238dc7445d78bf.tar.bz2
master-187ad058-dae7e90107f09031e05500e09a238dc7445d78bf.zip
remove lzma loader config option (make it default) and move it from package/ to target/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@530 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/target/Makefile b/target/Makefile
index c8baab5f7a..6a1bd954a0 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -29,20 +29,9 @@ IMAGE_TARGETS += $(BIN_DIR)/openwrt-motorola-$(1).bin
endif
endef
-# Enable loader and prepare kernel
-ifeq ($(strip $(BR2_PACKAGE_LOADER)),y)
-export LINUX_LOADER=$(BUILD_DIR)/lzmaldr
-export LINUX_IMAGE=$(BUILD_DIR)/piggy.lzma
-else
-export LINUX_IMAGE=$(BUILD_DIR)/piggy.gz
-endif
-
-$(BUILD_DIR)/piggy.lzma: $(LINUX_KERNEL)
+$(LINUX_IMAGE): $(LINUX_KERNEL)
cat $^ | $(BUILD_DIR)/lzma/lzma e -si -so -eos > $@ || (rm -f $@ && false)
-$(BUILD_DIR)/piggy.gz: $(LINUX_KERNEL)
- cat $^ | gzip -c9 $^ > $@ || (rm -f $@ && false)
-
TARGET_DIRS:=
TARGET_FS:=
IMAGE_TARGETS:=
@@ -83,6 +72,7 @@ prepare: $(patsubst %,%-prepare,$(TARGET_DIRS))
$(BIN_DIR):
mkdir -p $(BIN_DIR)
+$(INSTALL_TARGET_DIRS): lzma-loader-compile
compile: $(patsubst %,%-compile,$(TARGET_DIRS))
install: utils-install lzma-install $(LINUX_IMAGE) $(patsubst %,%-install,$(TARGET_DIRS)) $(IMAGE_TARGETS)
clean: $(patsubst %,%-clean,$(TARGET_DIRS)) image_clean