aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-06 17:24:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-06 17:24:05 +0000
commitc1a3f3f3dbc803564951a63df7872bcb6eb476da (patch)
tree8742d8a988f68d4472bd2fef20f99c9c343aacc1 /target/Makefile
parentbd86f88b0a718336b75fa4b082a1ffda897a8d99 (diff)
downloadmaster-187ad058-c1a3f3f3dbc803564951a63df7872bcb6eb476da.tar.gz
master-187ad058-c1a3f3f3dbc803564951a63df7872bcb6eb476da.tar.bz2
master-187ad058-c1a3f3f3dbc803564951a63df7872bcb6eb476da.zip
target: do not make target/*/install depend on target/*/compile - removes one redundant kernel build dir call on target/install
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32091 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/target/Makefile b/target/Makefile
index 81ec60234a..cb68454c91 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -10,10 +10,7 @@ $(curdir)/builddirs:=linux sdk imagebuilder toolchain
$(curdir)/builddirs-default:=linux
$(curdir)/builddirs-install:=linux $(if $(CONFIG_SDK),sdk) $(if $(CONFIG_IB),imagebuilder) $(if $(CONFIG_MAKE_TOOLCHAIN),toolchain)
-$(curdir)/imagebuilder/compile:=$(curdir)/linux/install
-
-# prerequisites for the individual targets
-$(curdir)//install = $(1)/compile
+$(curdir)/imagebuilder/install:=$(curdir)/linux/install
$(eval $(call stampfile,$(curdir),target,prereq,.config))
$(eval $(call stampfile,$(curdir),target,compile,$(TMP_DIR)/.build))