aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-26 00:41:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-26 00:41:53 +0000
commit93dbc52b0bd6a4af1ab5f5c777a34e29696884ba (patch)
tree1745aabc1cef822f3399fabd49543c5e57517956 /target/Makefile
parent73552f315ed45d67840177fc6d87b6087282d903 (diff)
downloadmaster-187ad058-93dbc52b0bd6a4af1ab5f5c777a34e29696884ba.tar.gz
master-187ad058-93dbc52b0bd6a4af1ab5f5c777a34e29696884ba.tar.bz2
master-187ad058-93dbc52b0bd6a4af1ab5f5c777a34e29696884ba.zip
use default_subtargets in package/Makefile and target/Makefile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6380 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/Makefile b/target/Makefile
index 724ac4450d..1b6cbb54ee 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -51,14 +51,4 @@ image_install: image_compile
imagebuilder_install: image_install
$(MAKE) -C imagebuilder install
-%-clean: FORCE
- $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-download: FORCE
- $(MAKE) -C $(patsubst %-download,%,$@) download
-%-prepare: FORCE
- $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
-%-compile: %-prepare
- $(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-install: %-compile
- $(MAKE) -C $(patsubst %-install,%,$@) install
-
+$(eval $(call default_subtargets,))