aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-18 17:35:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-18 17:35:46 +0000
commit9384678f1668a8fe6eea6e574b4a37e783294897 (patch)
treef62e1d27ecf30113b42e9664e88b35705e248222 /target/Makefile
parent8f952fb7715c3a2e7ff901b8becf8cbd11f642b7 (diff)
downloadmaster-187ad058-9384678f1668a8fe6eea6e574b4a37e783294897.tar.gz
master-187ad058-9384678f1668a8fe6eea6e574b4a37e783294897.tar.bz2
master-187ad058-9384678f1668a8fe6eea6e574b4a37e783294897.zip
the default_subtargets template was a bad idea, since different makefiles require different types of dependencies for subtargets. nuke it...
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7003 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/Makefile b/target/Makefile
index 1b6cbb54ee..9a7dff2a78 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -51,4 +51,5 @@ image_install: image_compile
imagebuilder_install: image_install
$(MAKE) -C imagebuilder install
-$(eval $(call default_subtargets,))
+%-prereq %-prepare %-download %-clean %-compile %-install: FORCE
+ $(MAKE) -C $* $(patsubst $*-%,%,$@)