aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-21 14:02:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-21 14:02:29 +0000
commit913e09274d6e6056319d307a841ce9554085fb03 (patch)
treea16d02a1e5f3bbadde4f85f030dce15958e4ba6e /target/Makefile
parentde6d89215358578ecc1905eaa1446cbd5d7d89c0 (diff)
downloadmaster-187ad058-913e09274d6e6056319d307a841ce9554085fb03.tar.gz
master-187ad058-913e09274d6e6056319d307a841ce9554085fb03.tar.bz2
master-187ad058-913e09274d6e6056319d307a841ce9554085fb03.zip
move target/linux/image to target/image
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4040 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/target/Makefile b/target/Makefile
index 0a1434472a..836469d171 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -1,4 +1,5 @@
include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
all: install
@@ -11,15 +12,23 @@ TARGETS-$(CONFIG_SDK) += sdk
linux-compile: utils-install
linux-install: $(BIN_DIR)
sdk-compile: linux-install
+image_install: linux-install
download: $(patsubst %,%-source,$(TARGETS-y))
prepare: linux-prepare
-compile: linux-compile
-install: image_clean $(patsubst %,%-install,$(TARGETS-y))
+compile: linux-compile image_compile
+install: image_clean $(patsubst %,%-install,$(TARGETS-y)) image_install
clean: $(patsubst %,%-clean,$(TARGETS-y)) image_clean
image_clean: FORCE
+ $(MAKE) -C image/$(BOARD) clean
rm -f $(BIN_DIR)/openwrt-*
+
+image_compile: FORCE
+ $(MAKE) -C image/$(BOARD) compile
+
+image_install: image_compile
+ $(MAKE) -C image/$(BOARD) install
%-clean: FORCE
$(MAKE) -C $(patsubst %-clean,%,$@) clean