aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 00:06:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 00:06:20 +0000
commit6d59cdfc48ad29af5e424155d3e42995f63327a3 (patch)
treea92ac9dac91681e2551a6aab8ad6fa24b9d91611 /target/Makefile
parent0384bd07ecaaebf4f5c7420fffe245e091e2802a (diff)
downloadmaster-187ad058-6d59cdfc48ad29af5e424155d3e42995f63327a3.tar.gz
master-187ad058-6d59cdfc48ad29af5e424155d3e42995f63327a3.tar.bz2
master-187ad058-6d59cdfc48ad29af5e424155d3e42995f63327a3.zip
large build system cleanup. added some stuff to control the verbosity level, but not complete, yet.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2221 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/Makefile b/target/Makefile
index e6156b48bf..a14749fcae 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -17,15 +17,21 @@ image_clean:
rm -f $(BIN_DIR)/openwrt-*
%-clean:
+ @$(TRACE) target/$(patsubst %-clean,%,$@)/clean
$(MAKE) -C $(patsubst %-clean,%,$@) clean
%-prepare:
+ @$(TRACE) target/$(patsubst %-prepare,%,$@)/prepare
$(MAKE) -C $(patsubst %-prepare,%,$@) prepare
%-compile: %-prepare
+ @$(TRACE) target/$(patsubst %-compile,%,$@)/compile
$(MAKE) -C $(patsubst %-compile,%,$@) compile
%-rebuild:
+ @$(TRACE) target/$(patsubst %-rebuild,%,$@)/rebuild
$(MAKE) -C $(patsubst %-rebuild,%,$@) rebuild
%-install: %-compile
+ @$(TRACE) target/$(patsubst %-install,%,$@)/install
$(MAKE) -C $(patsubst %-install,%,$@) install
linux-imagebuilder:
+ @$(TRACE) target/linux/imagebuilder
$(MAKE) -C linux imagebuilder