aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-17 22:52:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-17 22:52:59 +0000
commit6a0c7478207d03871e433e554829e6157897f326 (patch)
tree2b6844c3bb5831e464ea4625441fd91543579b32 /target/Makefile
parentef69b8d26a7c4250ed183cc2e1df394c0ef62282 (diff)
downloadmaster-187ad058-6a0c7478207d03871e433e554829e6157897f326.tar.gz
master-187ad058-6a0c7478207d03871e433e554829e6157897f326.tar.bz2
master-187ad058-6a0c7478207d03871e433e554829e6157897f326.zip
move target/default/target_skeleton into package/base-files, put all the default files in ipkg packages, cleanup some junk in toolchain/, toolchain/ no longer changes build_mipsel/root
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1494 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile29
1 files changed, 2 insertions, 27 deletions
diff --git a/target/Makefile b/target/Makefile
index 4f9c54144a..52b2e60cff 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -5,38 +5,13 @@ TARGET_SKEL_DIR=default/target_skeleton
all: install
-$(TARGET_DIR):
- mkdir -p $(TARGET_DIR)
- if [ -f "$(TARGET_SKELETON)" ] ; then \
- zcat $(TARGET_SKELETON) | tar -C $(BUILD_DIR) -xf -; \
- fi;
- if [ -d "$(TARGET_SKEL_DIR)" ] ; then \
- cp -a $(TARGET_SKEL_DIR)/* $(TARGET_DIR)/; \
- fi;
- mkdir -p $(TARGET_DIR)/jffs
- mkdir -p $(TARGET_DIR)/dev
- mkdir -p $(TARGET_DIR)/proc
- mkdir -p $(TARGET_DIR)/tmp
- mkdir -p $(TARGET_DIR)/lib
- mkdir -p $(TARGET_DIR)/usr/lib
- mkdir -p $(TARGET_DIR)/usr/bin
- ln -sf /tmp/resolv.conf $(TARGET_DIR)/etc/resolv.conf
- rm -rf $(TARGET_DIR)/var
- ln -sf /tmp $(TARGET_DIR)/var
- -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
- -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
-
$(BIN_DIR):
mkdir -p $(BIN_DIR)
-$(TARGET_DIR)/etc/sysconf:
- mkdir -p $(TARGET_DIR)/etc
- -grep \^BR2_SYSCONF $(TOPDIR)/.config > $(TARGET_DIR)/etc/sysconf
-
linux-compile: utils-install lzma-install
-linux-install: $(TARGET_DIR)/etc/sysconf $(BIN_DIR)
+linux-install: $(BIN_DIR)
-prepare: $(TARGET_DIR)
+prepare:
compile: linux-compile
install: image_clean linux-install
clean: linux-clean utils-clean lzma-clean image_clean