aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-31 23:29:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-31 23:29:05 +0000
commit56ca36174338f3a0029b39ed7782c0410cf2d2fe (patch)
tree8e70523a0c222f26aa84bf3382deceee6b406752 /target/Makefile
parent5f27fa5f8c930ad9de6c41028ffd4a8bad876e1b (diff)
downloadmaster-187ad058-56ca36174338f3a0029b39ed7782c0410cf2d2fe.tar.gz
master-187ad058-56ca36174338f3a0029b39ed7782c0410cf2d2fe.tar.bz2
master-187ad058-56ca36174338f3a0029b39ed7782c0410cf2d2fe.zip
cleanup; replace .PHONY with FORCE; disable gdb by default
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3877 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/Makefile b/target/Makefile
index 58fc5eb874..709a2080a5 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -13,20 +13,20 @@ compile: linux-compile
install: image_clean linux-install
clean: linux-clean utils-clean lzma-clean image_clean
-image_clean:
+image_clean: FORCE
rm -f $(BIN_DIR)/openwrt-*
-%-clean:
+%-clean: FORCE
$(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-prepare:
+%-prepare: FORCE
$(MAKE) -C $(patsubst %-prepare,%,$@) prepare
%-compile: %-prepare
$(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-rebuild:
+%-rebuild: FORCE
$(MAKE) -C $(patsubst %-rebuild,%,$@) rebuild
%-install: %-compile
$(MAKE) -C $(patsubst %-install,%,$@) install
-linux-imagebuilder:
+linux-imagebuilder: FORCE
$(MAKE) -C linux imagebuilder