aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-21 03:17:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-21 03:17:13 +0000
commit4da6c416ff6122d03e5f3ce6808e15e761e91564 (patch)
tree2f57e0d1e9bdcfefc647b6d8422dfed3156d7f0a /target/Makefile
parent5ba3b2085b8346ff0a9b73e836af3646c51e42e4 (diff)
downloadmaster-187ad058-4da6c416ff6122d03e5f3ce6808e15e761e91564.tar.gz
master-187ad058-4da6c416ff6122d03e5f3ce6808e15e761e91564.tar.bz2
master-187ad058-4da6c416ff6122d03e5f3ce6808e15e761e91564.zip
fix and enable the sdk
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4037 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/Makefile b/target/Makefile
index 9205f5b986..0a1434472a 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -5,16 +5,18 @@ all: install
$(BIN_DIR):
mkdir -p $(BIN_DIR)
-TARGETS:=linux utils
+TARGETS-y := linux utils
+TARGETS-$(CONFIG_SDK) += sdk
linux-compile: utils-install
linux-install: $(BIN_DIR)
+sdk-compile: linux-install
-download: $(patsubst %,%-source,$(TARGETS))
+download: $(patsubst %,%-source,$(TARGETS-y))
prepare: linux-prepare
compile: linux-compile
-install: image_clean linux-install
-clean: $(patsubst %,%-clean,$(TARGETS)) image_clean
+install: image_clean $(patsubst %,%-install,$(TARGETS-y))
+clean: $(patsubst %,%-clean,$(TARGETS-y)) image_clean
image_clean: FORCE
rm -f $(BIN_DIR)/openwrt-*