aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-28 09:17:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-28 09:17:29 +0000
commit1c4a2a55f76e481a2d1bc005405b9ce856d58939 (patch)
tree80dfa6ecb493ee8cb9ca1436f1b37ee89f320a55 /target/Makefile
parentfdd5681c06468a606180f04c2533c8ba213a37f6 (diff)
downloadmaster-187ad058-1c4a2a55f76e481a2d1bc005405b9ce856d58939.tar.gz
master-187ad058-1c4a2a55f76e481a2d1bc005405b9ce856d58939.tar.bz2
master-187ad058-1c4a2a55f76e481a2d1bc005405b9ce856d58939.zip
move package/linux into target/linux, use wbx' new kernel code. support building images with more than one kernel, split kernel module parts off of packages that use their own kernel modules (fuse, shfs, openswan). some cleanup in the image building process in target/. image builder is disabled for now, needs some fixing.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1085 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/target/Makefile b/target/Makefile
index 248bcffcde..05d0023d7b 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -5,12 +5,12 @@ TARGET_SKEL_DIR=default/target_skeleton
all: install
-define IMAGE_template
-$(BIN_DIR)/openwrt-wrt54g-$(1).bin: $(BIN_DIR)/openwrt-generic-$(patsubst jffs2,jffs2-4MB,$(1)).trx
+define BIN_template
+$(BIN_DIR)/openwrt-wrt54g-$(1).bin: $(BIN_DIR)/openwrt-brcm-2.4-$(patsubst jffs2,jffs2-4MB,$(1)).trx
PATH=$(TARGET_PATH) addpattern -2 -i $$< -o $$@ -g
$(SED) "1s,^W54S,W54G," $$@
-$(BIN_DIR)/openwrt-wrt54gs-$(1).bin: $(BIN_DIR)/openwrt-generic-$(patsubst jffs2,jffs2-8MB,$(1)).trx
+$(BIN_DIR)/openwrt-wrt54gs-$(1).bin: $(BIN_DIR)/openwrt-brcm-2.4-$(patsubst jffs2,jffs2-8MB,$(1)).trx
PATH=$(TARGET_PATH) addpattern -2 -i $$< -o $$@ -g
ifeq ($(BR2_TARGET_WRT54G),y)
@@ -21,7 +21,7 @@ IMAGE_TARGETS += $(BIN_DIR)/openwrt-wrt54gs-$(1).bin
endif
-$(BIN_DIR)/openwrt-motorola-$(1).bin: $(BIN_DIR)/openwrt-generic-$(patsubst jffs2,jffs2-8MB,$(1)).trx
+$(BIN_DIR)/openwrt-motorola-$(1).bin: $(BIN_DIR)/openwrt-brcm-2.4-$(patsubst jffs2,jffs2-8MB,$(1)).trx
PATH=$(TARGET_PATH) motorola-bin $$< $$@
ifeq ($(BR2_TARGET_MOTOROLA),y)
@@ -40,7 +40,7 @@ ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS_LZMA)),y)
TARGET_DIRS += squashfs-lzma
TARGET_FS += squashfs
endif
-$(foreach fs,$(TARGET_FS),$(eval $(call IMAGE_template,$(fs))))
+$(foreach fs,$(TARGET_FS),$(eval $(call BIN_template,$(fs))))
INSTALL_TARGET_DIRS:=$(patsubst %,%-install,$(TARGET_DIRS))
$(INSTALL_TARGET_DIRS): image_clean $(TARGET_DIR)/etc/sysconf $(BIN_DIR)
@@ -69,11 +69,11 @@ prepare: $(patsubst %,%-prepare,$(TARGET_DIRS))
$(BIN_DIR):
mkdir -p $(BIN_DIR)
-$(INSTALL_TARGET_DIRS): lzma-loader-compile
-$(IMAGE_TARGETS): $(patsubst %,%-install,$(TARGET_DIRS))
-compile: $(patsubst %,%-compile,jffs2 lzma squashfs-lzma lzma-loader utils)
-install: utils-install lzma-install $(patsubst %,%-install,$(TARGET_DIRS)) $(IMAGE_TARGETS)
-clean: $(patsubst %,%-clean,$(TARGET_DIRS)) image_clean
+$(INSTALL_TARGET_DIRS): lzma-loader-compile linux-install
+$(IMAGE_TARGETS): $(patsubst %,%-install,$(TARGET_DIRS) linux)
+compile: $(patsubst %,%-compile,jffs2 lzma squashfs-lzma lzma-loader utils linux)
+install: utils-install lzma-install $(patsubst %,%-install,$(TARGET_DIRS) linux) $(IMAGE_TARGETS)
+clean: $(patsubst %,%-clean,$(TARGET_DIRS) linux) image_clean
image_clean:
rm -f $(BIN_DIR)/openwrt-*