aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-21 02:16:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-21 02:16:37 +0000
commit08cbdbc1b095f079e37680c972b80079524290ad (patch)
tree783ba7c887edb58fc47a47c1d083b5a5e6a30ef3 /target/Makefile
parent71068dead931b6d63e12715290076c02c8e68382 (diff)
downloadmaster-187ad058-08cbdbc1b095f079e37680c972b80079524290ad.tar.gz
master-187ad058-08cbdbc1b095f079e37680c972b80079524290ad.tar.bz2
master-187ad058-08cbdbc1b095f079e37680c972b80079524290ad.zip
build system cleanup. move shared include files into $(TOPDIR)/include, move lzma, mkfs.* into toolchain/
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4032 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/target/Makefile b/target/Makefile
index d64053cbd4..9205f5b986 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -5,9 +5,9 @@ all: install
$(BIN_DIR):
mkdir -p $(BIN_DIR)
-TARGETS:=linux utils lzma
+TARGETS:=linux utils
-linux-compile: utils-install lzma-install
+linux-compile: utils-install
linux-install: $(BIN_DIR)
download: $(patsubst %,%-source,$(TARGETS))
@@ -27,11 +27,6 @@ image_clean: FORCE
$(MAKE) -C $(patsubst %-prepare,%,$@) prepare
%-compile: %-prepare
$(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-rebuild: FORCE
- $(MAKE) -C $(patsubst %-rebuild,%,$@) rebuild
%-install: %-compile
$(MAKE) -C $(patsubst %-install,%,$@) install
-linux-imagebuilder: FORCE
- $(MAKE) -C linux imagebuilder
-