aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile.in
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-02-19 07:46:01 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-02-19 07:46:01 +0000
commit6cd75a4cdf9aaa7f2312ab92791e434db787b044 (patch)
tree2e76bc79062dd04d82b22da4ee06c34af9563311 /target/Makefile.in
parentc75eeb62c560440292a753e9a8b17720c1aaa17e (diff)
downloadmaster-187ad058-6cd75a4cdf9aaa7f2312ab92791e434db787b044.tar.gz
master-187ad058-6cd75a4cdf9aaa7f2312ab92791e434db787b044.tar.bz2
master-187ad058-6cd75a4cdf9aaa7f2312ab92791e434db787b044.zip
sync with buildroot2 from uclibc, add devices, may be used to build other kernel modules for different devices, can be used for other stuff
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@267 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile.in')
-rw-r--r--target/Makefile.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/target/Makefile.in b/target/Makefile.in
index c01ade299a..802b576fba 100644
--- a/target/Makefile.in
+++ b/target/Makefile.in
@@ -1 +1,17 @@
-# Nothing
+# Default target skeleton stuff, may be overridden
+TARGET_SKELETON=target/default/skel.tar.gz
+TARGET_SKEL_DIR=target/default/target_skeleton
+
+include target/device/Makefile.in
+
+openwrt-linux.trx: openwrt-trx
+ PATH=$(TARGET_PATH) trx -o openwrt-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFS)
+
+openwrt-gs-code.bin: openwrt-addpattern openwrt-linux.trx
+ PATH=$(TARGET_PATH) addpattern -2 -i openwrt-linux.trx -o openwrt-gs-code.bin -g
+
+openwrt-g-code.bin: openwrt-gs-code.bin
+ sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin > openwrt-g-code.bin
+
+openwrt-image: openwrt-g-code.bin
+