aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/symlink-tree.sh
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-12-10 20:52:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-12-10 20:52:45 +0000
commitd8c10735b7c70c9fccfcfcee615ee3ade52ce082 (patch)
treee3e9b125d6285f502e04f2b8d72d51a1746ccec5 /scripts/symlink-tree.sh
parentd46ae9ced2f626637b3f64aa4c1789958a3d992c (diff)
downloadmaster-187ad058-d8c10735b7c70c9fccfcfcee615ee3ade52ce082.tar.gz
master-187ad058-d8c10735b7c70c9fccfcfcee615ee3ade52ce082.tar.bz2
master-187ad058-d8c10735b7c70c9fccfcfcee615ee3ade52ce082.zip
add a simple script for symlinking one tree into another for doing builds with separate build dirs, but the same source dir
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18734 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'scripts/symlink-tree.sh')
-rwxr-xr-xscripts/symlink-tree.sh45
1 files changed, 45 insertions, 0 deletions
diff --git a/scripts/symlink-tree.sh b/scripts/symlink-tree.sh
new file mode 100755
index 0000000000..8be5f6c967
--- /dev/null
+++ b/scripts/symlink-tree.sh
@@ -0,0 +1,45 @@
+#!/usr/bin/env bash
+# Create a new openwrt tree with symlinks pointing at the current tree
+# Usage: ./scripts/symlink-tree.sh <destination>
+
+FILES="
+ BSDmakefile
+ Config.in
+ LICENSE
+ Makefile
+ README
+ dl
+ docs
+ feeds.conf.default
+ include
+ package
+ rules.mk
+ scripts
+ target
+ toolchain
+ tools"
+
+if [ -f feeds.conf ] ; then
+ FILES="$FILES feeds.conf"
+fi
+
+if [ -z "$1" ]; then
+ echo "Syntax: $0 <destination>"
+ exit 1
+fi
+
+if [ -e "$1" ]; then
+ echo "Error: $1 already exists"
+ exit 1
+fi
+
+set -e # fail if any commands fails
+mkdir -p dl "$1"
+for file in $FILES; do
+ [ -e "$PWD/$file" ] || {
+ echo "ERROR: $file does not exist in the current tree"
+ exit 1
+ }
+ ln -s "$PWD/$file" "$1/"
+done
+exit 0