aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/metadata.pm
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-15 11:08:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-15 11:08:01 +0000
commitf7a7b550d3eb9e3ddf993143fe5531c54206e5a5 (patch)
tree5e2af4b559a085f837386ba47068627642e69caa /scripts/metadata.pm
parent9ccecb891f81af7a12107b4cd63bdcbb2f32e065 (diff)
downloadmaster-187ad058-f7a7b550d3eb9e3ddf993143fe5531c54206e5a5.tar.gz
master-187ad058-f7a7b550d3eb9e3ddf993143fe5531c54206e5a5.tar.bz2
master-187ad058-f7a7b550d3eb9e3ddf993143fe5531c54206e5a5.zip
scripts/metadata.pm: save target makefile names
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44780 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'scripts/metadata.pm')
-rw-r--r--scripts/metadata.pm3
1 files changed, 3 insertions, 0 deletions
diff --git a/scripts/metadata.pm b/scripts/metadata.pm
index aa82fcd95d..09273df3ad 100644
--- a/scripts/metadata.pm
+++ b/scripts/metadata.pm
@@ -34,6 +34,7 @@ sub parse_target_metadata($) {
my $file = shift;
my ($target, @target, $profile);
my %target;
+ my $makefile;
open FILE, "<$file" or do {
warn "Can't open file '$file': $!\n";
@@ -41,11 +42,13 @@ sub parse_target_metadata($) {
};
while (<FILE>) {
chomp;
+ /^Source-Makefile: \s*((.+\/)([^\/]+)\/Makefile)\s*$/ and $makefile = $1;
/^Target:\s*(.+)\s*$/ and do {
my $name = $1;
$target = {
id => $name,
board => $name,
+ makefile => $makefile,
boardconf => confstr($name),
conf => confstr($name),
profiles => [],