aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/deptest.sh
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-11-03 00:27:50 +0000
committerMichael Büsch <mb@bu3sch.de>2010-11-03 00:27:50 +0000
commit9e13ee5627f6de7ccf0d854c88524013f2cb2983 (patch)
treecfa9ee35b469e8afda64ac27ae6e940fe5c771c2 /scripts/deptest.sh
parent01a4d924f07be5d91e9d52f9c6da261c402367d8 (diff)
downloadmaster-187ad058-9e13ee5627f6de7ccf0d854c88524013f2cb2983.tar.gz
master-187ad058-9e13ee5627f6de7ccf0d854c88524013f2cb2983.tar.bz2
master-187ad058-9e13ee5627f6de7ccf0d854c88524013f2cb2983.zip
deptest: Check for .config
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23810 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'scripts/deptest.sh')
-rwxr-xr-xscripts/deptest.sh2
1 files changed, 2 insertions, 0 deletions
diff --git a/scripts/deptest.sh b/scripts/deptest.sh
index ad378bafcd..3a81659f7b 100755
--- a/scripts/deptest.sh
+++ b/scripts/deptest.sh
@@ -22,6 +22,8 @@ die()
[ -f "$BASEDIR/include/toplevel.mk" ] || \
die "Error: Could not find buildsystem base directory"
+[ -f "$BASEDIR/.config" ] || \
+ die "The buildsystem is not configured. Please run make menuconfig."
cd "$BASEDIR" || die "Failed to enter base directory"
mkdir -p "$STAMP_DIR_SUCCESS" "$STAMP_DIR_FAILED" "$BUILD_DIR" "$BUILD_DIR_HOST" "$LOG_DIR"