aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-05-06 16:45:51 +0000
committerJohn Crispin <blogic@openwrt.org>2013-05-06 16:45:51 +0000
commitd8eb7a4cafa663023693b2204165c601bbee43df (patch)
treea3974aba7c24d64fc6236e966f39a9fd9ad65c4a /rules.mk
parent399d08c624931f67bc3dc9ce244121eb23d3546f (diff)
downloadmaster-187ad058-d8eb7a4cafa663023693b2204165c601bbee43df.tar.gz
master-187ad058-d8eb7a4cafa663023693b2204165c601bbee43df.tar.bz2
master-187ad058-d8eb7a4cafa663023693b2204165c601bbee43df.zip
rules.mk: add _dsp to ARCH_SUFFIX if the dsp ase is used
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36566 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 2333f2aaf5..b9510057b6 100644
--- a/rules.mk
+++ b/rules.mk
@@ -63,6 +63,12 @@ endif
ifneq ($(filter -mips%r2,$(TARGET_OPTIMIZATION)),)
ARCH_SUFFIX:=_r2
endif
+ifneq ($(filter -mdsp,$(TARGET_OPTIMIZATION)),)
+ ARCH_SUFFIX:=$(ARCH_SUFFIX)_dsp
+endif
+ifneq ($(filter -mdspr2,$(TARGET_OPTIMIZATION)),)
+ ARCH_SUFFIX:=$(ARCH_SUFFIX)_dspr2
+endif
ifdef CONFIG_USE_MIPS16
TARGET_OPTIMIZATION+= -minterlink-mips16 -mips16
endif