aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-05 16:57:18 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-05 16:57:18 +0000
commitb65868e9547bcd5cbb1b2a285d3cb0350e02f14c (patch)
treef1de773bdb38fcc416f5c7d645d58ec7844a68ee /rules.mk
parent87511c86a7e3a4575c61c2e2dbed55eb6f77f7de (diff)
downloadmaster-187ad058-b65868e9547bcd5cbb1b2a285d3cb0350e02f14c.tar.gz
master-187ad058-b65868e9547bcd5cbb1b2a285d3cb0350e02f14c.tar.bz2
master-187ad058-b65868e9547bcd5cbb1b2a285d3cb0350e02f14c.zip
include: declare variables formerly set in tmp/.host.mk
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44272 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 70768f055d..e5f681aeb2 100644
--- a/rules.mk
+++ b/rules.mk
@@ -210,6 +210,12 @@ CP:=cp -fpR
LN:=ln -sf
XARGS:=xargs -r
+BASH:=$(STAGING_DIR_HOST)/bin/bash
+TAR:=$(STAGING_DIR_HOST)/bin/tar
+FIND:=$(STAGING_DIR_HOST)/bin/find
+PATCH:=$(STAGING_DIR_HOST)/bin/patch
+PYTHON:=$(STAGING_DIR_HOST)/bin/python
+
INSTALL_BIN:=install -m0755
INSTALL_DIR:=install -d -m0755
INSTALL_DATA:=install -m0644