aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-01-14 12:28:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-01-14 12:28:53 +0000
commit7dca742180f1477905d55f1c972868c0c6705b91 (patch)
tree30ee86a6441a77f5942af7c00d910b522c7c72ec /rules.mk
parent72353d1fa0e5d306ab89cd9214b938a87edf7bbd (diff)
downloadmaster-187ad058-7dca742180f1477905d55f1c972868c0c6705b91.tar.gz
master-187ad058-7dca742180f1477905d55f1c972868c0c6705b91.tar.bz2
master-187ad058-7dca742180f1477905d55f1c972868c0c6705b91.zip
add $(TOOLCHAIN_DIR)/lib to $(TARGET_LDFLAGS) to ensure that all packages process this correctly - fixes build errors with openldap/php5
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10190 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 7ac39b123e..da16ed4466 100644
--- a/rules.mk
+++ b/rules.mk
@@ -59,7 +59,7 @@ endif
TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(STAGING_DIR_HOST)/bin:$(STAGING_DIR)/host/bin:$(PATH)
TARGET_CFLAGS:=$(TARGET_OPTIMIZATION) -fhonour-copts
TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
-TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+TARGET_LDFLAGS:=-L$(TOOLCHAIN_DIR)/lib -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
ifeq ($(CONFIG_SOFT_FLOAT),y)
SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft