aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-08-14 13:02:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-08-14 13:02:29 +0000
commit64584aa1fcecfa733e4ef83d294280bce9f2922b (patch)
treef0eedc5fad943b44693a84a35e5c58140e6c5919 /rules.mk
parentec784b73562dc5afc0f6badb5b63fe02e58d237a (diff)
downloadmaster-187ad058-64584aa1fcecfa733e4ef83d294280bce9f2922b.tar.gz
master-187ad058-64584aa1fcecfa733e4ef83d294280bce9f2922b.tar.bz2
master-187ad058-64584aa1fcecfa733e4ef83d294280bce9f2922b.zip
build: decouple the mips16 support flag from the toolchain
Add the flags from package.mk instead, and leave libc and gcc unaffected. Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37770 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk10
1 files changed, 2 insertions, 8 deletions
diff --git a/rules.mk b/rules.mk
index 48be224858..14171a0d30 100644
--- a/rules.mk
+++ b/rules.mk
@@ -70,13 +70,6 @@ endif
ifneq ($(filter -mdspr2,$(TARGET_OPTIMIZATION)),)
ARCH_SUFFIX:=$(ARCH_SUFFIX)_dspr2
endif
-ifdef CONFIG_USE_MIPS16
- TARGET_OPTIMIZATION+= -minterlink-mips16 -mips16
-endif
-ifneq ($(findstring -mips16,$(TARGET_OPTIMIZATION)),)
- TARGET_ASFLAGS_OVERRIDE:=-mno-mips16
- ARCH_SUFFIX:= $(ARCH_SUFFIX)_m16
-endif
ifdef CONFIG_HAS_SPE_FPU
TARGET_SUFFIX:=$(TARGET_SUFFIX)spe
endif
@@ -130,7 +123,8 @@ PKG_INFO_DIR := $(STAGING_DIR)/pkginfo
TARGET_PATH:=$(STAGING_DIR_HOST)/bin:$(subst $(space),:,$(filter-out .,$(filter-out ./,$(subst :,$(space),$(PATH)))))
TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3) $(EXTRA_OPTIMIZATION)
TARGET_CXXFLAGS = $(TARGET_CFLAGS)
-TARGET_ASFLAGS = $(TARGET_CFLAGS) $(TARGET_ASFLAGS_OVERRIDE)
+TARGET_ASFLAGS_DEFAULT = $(TARGET_CFLAGS)
+TARGET_ASFLAGS = $(TARGET_ASFLAGS_DEFAULT)
TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
ifneq ($(CONFIG_EXTERNAL_TOOLCHAIN),)