aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-22 08:57:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-22 08:57:20 +0000
commit3da7d959658483485d41d81db6b7b459aa8a8cdd (patch)
tree43ce537c81ae69e835de225dbfcdbc9d309e683d /rules.mk
parent09976aa5627eb857d7cc097a0209af21033fbe27 (diff)
downloadmaster-187ad058-3da7d959658483485d41d81db6b7b459aa8a8cdd.tar.gz
master-187ad058-3da7d959658483485d41d81db6b7b459aa8a8cdd.tar.bz2
master-187ad058-3da7d959658483485d41d81db6b7b459aa8a8cdd.zip
rules.mk: reduce shexport to one line to allow it to be put in a target context
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43018 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/rules.mk b/rules.mk
index 8844a47a1f..0822979012 100644
--- a/rules.mk
+++ b/rules.mk
@@ -278,8 +278,7 @@ V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
endef
define shexport
-$(call shvar,$(1))=$$(call $(1))
-export $(call shvar,$(1))
+export $(call shvar,$(1))=$$(call $(1))
endef
define include_mk