aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-10 12:04:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-10 12:04:09 +0000
commit2dcb4abe675bf50803e791057f4f5dd6ddfc6eec (patch)
tree734f7ca9643e4e846ff26b29b38724115fd50a4b /rules.mk
parentd0036c92b0f0ebd16a62ccb211c1ca40203a7df3 (diff)
downloadmaster-187ad058-2dcb4abe675bf50803e791057f4f5dd6ddfc6eec.tar.gz
master-187ad058-2dcb4abe675bf50803e791057f4f5dd6ddfc6eec.tar.bz2
master-187ad058-2dcb4abe675bf50803e791057f4f5dd6ddfc6eec.zip
build: add -Wno-error=unused-result to target cflags
Many glibc functions have __warn_unused_result__ in so many different core functions, and failing the build for all of those simply does not make any sense Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47440 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 348b45d6e1..f749863d7c 100644
--- a/rules.mk
+++ b/rules.mk
@@ -143,7 +143,7 @@ ifndef DUMP
-include $(TOOLCHAIN_DIR)/info.mk
export GCC_HONOUR_COPTS:=0
TARGET_CROSS:=$(if $(TARGET_CROSS),$(TARGET_CROSS),$(OPTIMIZE_FOR_CPU)-openwrt-linux$(if $(TARGET_SUFFIX),-$(TARGET_SUFFIX))-)
- TARGET_CFLAGS+= -fhonour-copts -Wno-error=unused-but-set-variable
+ TARGET_CFLAGS+= -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result
TARGET_CPPFLAGS+= -I$(TOOLCHAIN_DIR)/usr/include
ifeq ($(CONFIG_USE_MUSL),y)
TARGET_CPPFLAGS+= -I$(TOOLCHAIN_DIR)/include/fortify