aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-01-02 19:45:50 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-01-02 19:45:50 +0000
commitfe02917a548b9fc4a9103465b4c8a8bf0c2c4d31 (patch)
tree8c7511913298d2df5bcd97c24f2e3ea701236f36 /package
parent71831618f44f547cb7be0699c37c8411ef353339 (diff)
downloadmaster-187ad058-fe02917a548b9fc4a9103465b4c8a8bf0c2c4d31.tar.gz
master-187ad058-fe02917a548b9fc4a9103465b4c8a8bf0c2c4d31.tar.bz2
master-187ad058-fe02917a548b9fc4a9103465b4c8a8bf0c2c4d31.zip
[package] fix zlib linking failures with gcc-4.4+ (#6173)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19012 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/zlib/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/zlib/Makefile b/package/zlib/Makefile
index 19457c1ac8..d8213b972d 100644
--- a/package/zlib/Makefile
+++ b/package/zlib/Makefile
@@ -39,6 +39,7 @@ endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
+ LDSHARED="$(TARGET_CROSS)ld -shared" \
CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
libz.a libz.so
mkdir -p $(PKG_INSTALL_DIR)