aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-21 00:20:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-21 00:20:42 +0000
commitfa98e6a6e4ade1490be6a5225e49242007aa6d5f (patch)
treee93dafddc18aa224bc6aa252d2eb94756f85a85c /package
parent020508d5cba56a1970d2351f59c3ad407fc70fee (diff)
downloadmaster-187ad058-fa98e6a6e4ade1490be6a5225e49242007aa6d5f.tar.gz
master-187ad058-fa98e6a6e4ade1490be6a5225e49242007aa6d5f.tar.bz2
master-187ad058-fa98e6a6e4ade1490be6a5225e49242007aa6d5f.zip
madwifi: reduce the size of the multicall tool binary
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18112 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/madwifi/patches/200-no_debug.patch7
-rw-r--r--package/madwifi/patches/424-timing.patch2
2 files changed, 5 insertions, 4 deletions
diff --git a/package/madwifi/patches/200-no_debug.patch b/package/madwifi/patches/200-no_debug.patch
index 5e5eb04547..d5f285c241 100644
--- a/package/madwifi/patches/200-no_debug.patch
+++ b/package/madwifi/patches/200-no_debug.patch
@@ -173,16 +173,17 @@
if(strcmp(progname, "athstats") == 0)
--- a/tools/Makefile
+++ b/tools/Makefile
-@@ -48,6 +48,8 @@ endif
+@@ -48,14 +48,16 @@ endif
all: compile
+DEBUG = -DAR_DEBUG
+
ALLPROGS= athstats 80211stats athkey athchans athctrl \
- athdebug 80211debug wlanconfig ath_info
+- athdebug 80211debug wlanconfig ath_info
++ $(if $(DEBUG),athdebug 80211debug) wlanconfig ath_info
-@@ -55,7 +57,7 @@ OBJS= $(patsubst %,%.o,$(ALLPROGS))
+ OBJS= $(patsubst %,%.o,$(ALLPROGS))
INCS= -I. -I../ath -I$(HAL) -I$(TOP) -I$(ATH_HAL)
CFLAGS= -g -O2 -Wall
diff --git a/package/madwifi/patches/424-timing.patch b/package/madwifi/patches/424-timing.patch
index 4dfa3c97a6..a8b82fa104 100644
--- a/package/madwifi/patches/424-timing.patch
+++ b/package/madwifi/patches/424-timing.patch
@@ -568,7 +568,7 @@
-ALLPROGS= athstats 80211stats athkey athchans athctrl \
+ALLPROGS= athstats 80211stats athkey athchans \
- athdebug 80211debug wlanconfig ath_info
+ $(if $(DEBUG),athdebug 80211debug) wlanconfig ath_info
OBJS= $(patsubst %,%.o,$(ALLPROGS))
--- a/tools/athctrl.c