aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-19 23:03:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-19 23:03:09 +0000
commitf97352b6f868c2e0da6cdbf3aba932ea0ac63b40 (patch)
tree33cd34442a64e65ab913b14544d434d0dda62a02 /package
parentbeedcf12afdaa192bc589a201ff6746a74b90583 (diff)
downloadmaster-187ad058-f97352b6f868c2e0da6cdbf3aba932ea0ac63b40.tar.gz
master-187ad058-f97352b6f868c2e0da6cdbf3aba932ea0ac63b40.tar.bz2
master-187ad058-f97352b6f868c2e0da6cdbf3aba932ea0ac63b40.zip
fix libnl include issues which broke a few packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9581 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/hostapd/Makefile2
-rw-r--r--package/libnl/Makefile3
2 files changed, 3 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index fb8b92d432..f196828c97 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -83,7 +83,7 @@ define Build/ConfigureTarget
endef
define Build/CompileTarget
- CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/madwifi -I$(STAGING_DIR)/usr/include/mac80211 -I$(STAGING_DIR)/usr/include" \
+ CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/madwifi -I$(STAGING_DIR)/usr/include/mac80211 -I$(STAGING_DIR)/usr/include/libnl -I$(STAGING_DIR)/usr/include" \
$(MAKE) -C $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd \
$(TARGET_CONFIGURE_OPTS) \
LIBS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib \
diff --git a/package/libnl/Makefile b/package/libnl/Makefile
index 28958f4a51..d232c77b3f 100644
--- a/package/libnl/Makefile
+++ b/package/libnl/Makefile
@@ -39,7 +39,8 @@ endef
ifneq ($(CONFIG_LINUX_2_6_23),)
define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
- $(CP) $(PKG_BUILD_DIR)/include/linux $(1)/usr/include/
+ mkdir -p $(1)/usr/include/libnl
+ $(CP) $(PKG_BUILD_DIR)/include/linux $(1)/usr/include/libnl/
endef
define Build/UninstallDev