aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-04 20:03:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-04 20:03:26 +0000
commitf73469514da729545c6425fd22d3f24230e29a4e (patch)
treed3d62e1c52237d466a0daa41ece1e65f51cbe94f /package
parent652c662b7d60403024fe618a9bde3baaaec57ffb (diff)
downloadmaster-187ad058-f73469514da729545c6425fd22d3f24230e29a4e.tar.gz
master-187ad058-f73469514da729545c6425fd22d3f24230e29a4e.tar.bz2
master-187ad058-f73469514da729545c6425fd22d3f24230e29a4e.zip
move arch specific base-files install call to the end of the generic one - fixes wrong /etc/config/network
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4914 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 1e234c65a3..9f6da3bc7c 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -142,7 +142,6 @@ define Package/base-files$(TARGET)/install-brcm
endef
define Package/base-files$(TARGET)/install
- $(call Package/base-files$(TARGET)/install-$(BOARD),$(1))
$(CP) ./default/* $(1)/
if [ -d $(BOARD)-$(KERNEL) ]; then \
$(CP) $(BOARD)-$(KERNEL)/* $(1)/; \
@@ -164,6 +163,7 @@ define Package/base-files$(TARGET)/install
rm -f $(1)/var
ln -sf /tmp $(1)/var
mkdir -p $(1)/etc
+$(call Package/base-files$(TARGET)/install-$(BOARD),$(1))
endef
define Package/libgcc/install