aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-03-08 19:21:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-03-08 19:21:55 +0000
commitec86a16556c311bc2c6fa1ddc812dd5b16905165 (patch)
tree1ca06c9e072d080a8a7850416963df2c835ba071 /package
parentcfd563d0c026b7c8ce98b1c63e0b281e46e5c06f (diff)
downloadmaster-187ad058-ec86a16556c311bc2c6fa1ddc812dd5b16905165.tar.gz
master-187ad058-ec86a16556c311bc2c6fa1ddc812dd5b16905165.tar.bz2
master-187ad058-ec86a16556c311bc2c6fa1ddc812dd5b16905165.zip
[brcm63xx] package the bcm63xx-spi driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14794 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 8499c461f9..4d657f118d 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -752,6 +752,21 @@ endef
$(eval $(call KernelPackage,spi-dev))
+define KernelPackage/bcm63xx-spi
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Broadcom BCM63xx SPI driver
+ DEPENDS:=@TARGET_brcm63xx +kmod-spi-bitbang
+ KCONFIG:=CONFIG_SPI_BCM63XX
+ FILES:=$(LINUX_DIR)/drivers/spi/bcm63xx_spi.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,92,bcm63xx_spi)
+endef
+
+define KernelPackage/bcm63xx-spi/description
+ This package contains the Broadcom BCM63xx SPI Master driver
+endef
+
+$(eval $(call KernelPackage,bcm63xx-spi))
+
define KernelPackage/cs5535-gpio
SUBMENU:=$(OTHER_MENU)
TITLE:=AMD CS5535/CS5536 GPIO driver