aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-12-31 15:40:13 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-12-31 15:40:13 +0000
commitda0bc0297934e1824a246778764a264555a391b4 (patch)
tree0c846a329913c6543043f9ff62f252fa4138a0e1 /package
parent6173d17c876bed59599f61dcdec68d9c1b4fd3ac (diff)
downloadmaster-187ad058-da0bc0297934e1824a246778764a264555a391b4.tar.gz
master-187ad058-da0bc0297934e1824a246778764a264555a391b4.tar.bz2
master-187ad058-da0bc0297934e1824a246778764a264555a391b4.zip
Fix the lock warning (#1111), also add another download source
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/busybox/Makefile3
-rw-r--r--package/busybox/patches/340-lock_util.patch3
2 files changed, 4 insertions, 2 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 2688777c00..2927d70436 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -13,7 +13,8 @@ PKG_VERSION:=1.3.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.busybox.net/downloads
+PKG_SOURCE_URL:=http://www.busybox.net/downloads \
+ http://distfiles.gentoo.org/distfiles/
PKG_MD5SUM:=571531cfa83726947ccb566de017ad4f
PKG_CAT:=bzcat
diff --git a/package/busybox/patches/340-lock_util.patch b/package/busybox/patches/340-lock_util.patch
index f832df7d91..a92fa3e047 100644
--- a/package/busybox/patches/340-lock_util.patch
+++ b/package/busybox/patches/340-lock_util.patch
@@ -39,7 +39,7 @@ diff -ruN busybox-1.3.1-old/miscutils/Kbuild busybox-1.3.1/miscutils/Kbuild
diff -ruN busybox-1.3.1-old/miscutils/lock.c busybox-1.3.1/miscutils/lock.c
--- busybox-1.3.1-old/miscutils/lock.c 1970-01-01 01:00:00.000000000 +0100
+++ busybox-1.3.1/miscutils/lock.c 2006-12-28 03:11:36.000000000 +0100
-@@ -0,0 +1,135 @@
+@@ -0,0 +1,136 @@
+/*
+ * Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
+ *
@@ -136,6 +136,7 @@ diff -ruN busybox-1.3.1-old/miscutils/lock.c busybox-1.3.1/miscutils/lock.c
+
+ return 0;
+ }
++ return 0;
+}
+
+#ifndef CONFIG_LOCK