aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-10-30 22:35:54 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-10-30 22:35:54 +0000
commitd9eabaa6daeda6afb629677a99f0c791f0364963 (patch)
tree4c0e3ccacf12477045a9eb30f7e25a9e4d7fb82a /package
parent6ffd3bd02c4666d62890ba95c858caca30c34cea (diff)
downloadmaster-187ad058-d9eabaa6daeda6afb629677a99f0c791f0364963.tar.gz
master-187ad058-d9eabaa6daeda6afb629677a99f0c791f0364963.tar.bz2
master-187ad058-d9eabaa6daeda6afb629677a99f0c791f0364963.zip
[package] prefer the cs5535 gpiolib driver after 2.6.32
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23728 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index b5b659a967..623f5078e8 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -167,9 +167,15 @@ define KernelPackage/gpio-cs5535
SUBMENU:=$(OTHER_MENU)
TITLE:=AMD CS5535/CS5536 GPIO driver
DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_CS5535_GPIO
+ KCONFIG:=CONFIG_CS5535_GPIO \
+ CONFIG_GPIO_CS5535
+ifeq ($(CONFIG_LINUX_2_6_32),y)
FILES:=$(LINUX_DIR)/drivers/char/cs5535_gpio.ko
AUTOLOAD:=$(call AutoLoad,50,cs5535_gpio)
+else
+ FILES:=$(LINUX_DIR)/drivers/gpio/cs5535-gpio.ko
+ AUTOLOAD:=$(call AutoLoad,50,cs5535-gpio)
+endif
endef
define KernelPackage/gpio-cs5535/description