aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-04-01 15:59:13 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-04-01 15:59:13 +0000
commitd8c87d909f46fdfe8b0935e6ab39ed238710e4a7 (patch)
tree4323510a865e7ad11bd365711f500549b29e0779 /package
parent5b4a6126704068b779151ecb0856b313e07ad798 (diff)
downloadmaster-187ad058-d8c87d909f46fdfe8b0935e6ab39ed238710e4a7.tar.gz
master-187ad058-d8c87d909f46fdfe8b0935e6ab39ed238710e4a7.tar.bz2
master-187ad058-d8c87d909f46fdfe8b0935e6ab39ed238710e4a7.zip
small compile fix for gcc 3.4.3
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@503 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/ebtables/Makefile1
-rw-r--r--package/ebtables/patches/gcc3.4-ebtables_c.patch10
2 files changed, 11 insertions, 0 deletions
diff --git a/package/ebtables/Makefile b/package/ebtables/Makefile
index 3f0b467ba4..809caf3c0e 100644
--- a/package/ebtables/Makefile
+++ b/package/ebtables/Makefile
@@ -19,6 +19,7 @@ $(DL_DIR)/$(PKG_SOURCE):
$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ $(PATCH) $(PKG_BUILD_DIR) ./patches
touch $(PKG_BUILD_DIR)/.unpacked
$(PKG_BUILD_DIR)/ebtables: $(PKG_BUILD_DIR)/.unpacked
diff --git a/package/ebtables/patches/gcc3.4-ebtables_c.patch b/package/ebtables/patches/gcc3.4-ebtables_c.patch
new file mode 100644
index 0000000000..1973ea57f7
--- /dev/null
+++ b/package/ebtables/patches/gcc3.4-ebtables_c.patch
@@ -0,0 +1,10 @@
+--- ebtables-v2.0.6/ebtables.c 2003-11-02 19:22:56.000000000 +0100
++++ ebtables-patch/ebtables.c 2005-03-29 08:03:09.734707134 +0200
+@@ -1171,6 +1171,7 @@
+ continue;
+ return i;
+ letscontinue:
++ {};
+ }
+ return -1;
+ }