aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-12 19:50:57 +0000
committerJohn Crispin <blogic@openwrt.org>2015-03-12 19:50:57 +0000
commitd5f527f3cee5cec5744d2a6f3ccd2cdae7adaca8 (patch)
tree5236aa6a2ac180eacc86c1739a57f41619119077 /package
parenta00f7e5cb5fbb3dd1486a3623d2b3428a6b07a79 (diff)
downloadmaster-187ad058-d5f527f3cee5cec5744d2a6f3ccd2cdae7adaca8.tar.gz
master-187ad058-d5f527f3cee5cec5744d2a6f3ccd2cdae7adaca8.tar.bz2
master-187ad058-d5f527f3cee5cec5744d2a6f3ccd2cdae7adaca8.zip
toolchain: The glorious return of glibc, ver 2.21
It's the eglibc packaging with a bit of spit-polishing. And testing. :-) [blogic: merged glibc and eglibc into 1 and made eglibc a glibc variant] Signed-off-by: Jeff Waugh <jdub@bethesignal.org> Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44701 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/libs/toolchain/Makefile10
-rw-r--r--package/libs/toolchain/glibc-files/etc/nsswitch.conf13
2 files changed, 18 insertions, 5 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 42b9935148..a3f8a9f6fb 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -420,12 +420,12 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(CP) $(TOOLCHAIN_DIR)/lib/libstdc++.so.* $(1)/usr/lib/
endef
- use_libutil=$(if $(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),libutil)
- use_libnsl=$(if $(CONFIG_EGLIBC_OPTION_EGLIBC_NIS),libnsl)
- use_nsswitch=$(if $(CONFIG_EGLIBC_OPTION_EGLIBC_NSSWITCH),libnss_dns libnss_files)
+ use_libutil=$(if $(CONFIG_GLIBC_USE_VERSION_2_21)$(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),libutil)
+ use_libnsl=$(if $(CONFIG_GLIBC_USE_VERSION_2_21)$(CONFIG_EGLIBC_OPTION_EGLIBC_NIS),libnsl)
+ use_nsswitch=$(if $(CONFIG_GLIBC_USE_VERSION_2_21)$(CONFIG_EGLIBC_OPTION_EGLIBC_NSSWITCH),libnss_dns libnss_files)
- define Package/eglibc/install
- $(CP) ./eglibc-files/* $(1)/
+ define Package/glibc/install
+ $(CP) ./glibc-files/* $(1)/
rm -f $(1)/etc/localtime
$(LN) /tmp/localtime $(1)/etc/localtime
$(INSTALL_DIR) $(1)/lib
diff --git a/package/libs/toolchain/glibc-files/etc/nsswitch.conf b/package/libs/toolchain/glibc-files/etc/nsswitch.conf
new file mode 100644
index 0000000000..981c425da6
--- /dev/null
+++ b/package/libs/toolchain/glibc-files/etc/nsswitch.conf
@@ -0,0 +1,13 @@
+passwd:files
+shadow:files
+group:files
+hosts:dns files
+bootparams:files
+ethers:files
+netmasks:files
+networks:files
+protocols:files
+rpc:files
+services:files
+automount:files
+aliases:files