aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-11-29 23:45:53 +0000
committerLuka Perkov <luka@openwrt.org>2014-11-29 23:45:53 +0000
commitd498e13cc99551e10fff62ceb4f3f1028e9c9258 (patch)
treec504a005ef3cba5b1d9a14673da0f23cb161333e /package
parentaa032d78d72b8a9f0f917e6055bfb53d2feefd0c (diff)
downloadmaster-187ad058-d498e13cc99551e10fff62ceb4f3f1028e9c9258.tar.gz
master-187ad058-d498e13cc99551e10fff62ceb4f3f1028e9c9258.tar.bz2
master-187ad058-d498e13cc99551e10fff62ceb4f3f1028e9c9258.zip
[package] uboot-*: update license info in uboot packages
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43429 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-ar71xx/Makefile3
-rw-r--r--package/boot/uboot-envtools/Makefile3
-rw-r--r--package/boot/uboot-kirkwood/Makefile3
-rw-r--r--package/boot/uboot-lantiq/Makefile3
-rw-r--r--package/boot/uboot-mxs/Makefile3
-rw-r--r--package/boot/uboot-omap/Makefile3
-rw-r--r--package/boot/uboot-oxnas/Makefile3
-rw-r--r--package/boot/uboot-pxa/Makefile3
-rw-r--r--package/boot/uboot-sunxi/Makefile3
-rw-r--r--package/boot/uboot-xburst/Makefile3
10 files changed, 30 insertions, 0 deletions
diff --git a/package/boot/uboot-ar71xx/Makefile b/package/boot/uboot-ar71xx/Makefile
index 1955bd8eeb..7c4bb6ce8a 100644
--- a/package/boot/uboot-ar71xx/Makefile
+++ b/package/boot/uboot-ar71xx/Makefile
@@ -20,6 +20,9 @@ PKG_SOURCE_URL:= \
PKG_MD5SUM:=
PKG_TARGETS:=bin
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
include $(INCLUDE_DIR)/package.mk
define uboot/Default
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 1db290eeb2..a6467e1d2d 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -23,6 +23,9 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/u-boot-$(PKG_VERSION)
PKG_BUILD_DEPENDS:=+fstools
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
include $(INCLUDE_DIR)/package.mk
define Package/uboot-envtools
diff --git a/package/boot/uboot-kirkwood/Makefile b/package/boot/uboot-kirkwood/Makefile
index f12c13bda2..2f4a1bbbfe 100644
--- a/package/boot/uboot-kirkwood/Makefile
+++ b/package/boot/uboot-kirkwood/Makefile
@@ -19,6 +19,9 @@ PKG_SOURCE_URL:= \
PKG_MD5SUM:=36d4bad687edcafa396fee607e505d4e
PKG_TARGETS:=bin
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index 9b20777895..d2b868f5de 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -19,6 +19,9 @@ PKG_SOURCE_URL:= \
PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
PKG_TARGETS:=bin
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
PKG_BUILD_PARALLEL:=1
FIRMWARE_LANTIQ_SOURCE:=$(TOPDIR)/target/linux/lantiq/files/firmware/lantiq
diff --git a/package/boot/uboot-mxs/Makefile b/package/boot/uboot-mxs/Makefile
index a6773b8d17..6541375094 100644
--- a/package/boot/uboot-mxs/Makefile
+++ b/package/boot/uboot-mxs/Makefile
@@ -18,6 +18,9 @@ PKG_SOURCE_URL:= \
ftp://ftp.denx.de/pub/u-boot
PKG_MD5SUM:=36d4bad687edcafa396fee607e505d4e
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
include $(INCLUDE_DIR)/package.mk
define uboot/Default
diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
index 96168a30d0..6e836d047a 100644
--- a/package/boot/uboot-omap/Makefile
+++ b/package/boot/uboot-omap/Makefile
@@ -19,6 +19,9 @@ PKG_SOURCE_URL:= \
PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
PKG_TARGETS:=bin
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
include $(INCLUDE_DIR)/package.mk
define uboot/Default
diff --git a/package/boot/uboot-oxnas/Makefile b/package/boot/uboot-oxnas/Makefile
index 42f3cf9f1a..aee7808c51 100644
--- a/package/boot/uboot-oxnas/Makefile
+++ b/package/boot/uboot-oxnas/Makefile
@@ -20,6 +20,9 @@ PKG_SOURCE_URL:= \
PKG_MD5SUM:=6d2116d1385a66e9a59742caa9d62a54
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
include $(INCLUDE_DIR)/package.mk
define uboot/Default
diff --git a/package/boot/uboot-pxa/Makefile b/package/boot/uboot-pxa/Makefile
index 7fe747cf0c..9dae1af6cf 100644
--- a/package/boot/uboot-pxa/Makefile
+++ b/package/boot/uboot-pxa/Makefile
@@ -18,6 +18,9 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=ca6bf3ef6ac5f5132a359b43dfa31e07076b74b7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
include $(INCLUDE_DIR)/package.mk
define uboot/Default
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index d8bee16040..e650051b7b 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -16,6 +16,9 @@ PKG_SOURCE_URL:= \
PKG_SOURCE_VERSION:=6d2116d1385a66e9a59742caa9d62a54
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
include $(INCLUDE_DIR)/package.mk
define uboot/Default
diff --git a/package/boot/uboot-xburst/Makefile b/package/boot/uboot-xburst/Makefile
index 89802d0f40..4a701f8f10 100644
--- a/package/boot/uboot-xburst/Makefile
+++ b/package/boot/uboot-xburst/Makefile
@@ -20,6 +20,9 @@ PKG_SOURCE_URL:= \
PKG_MD5SUM:=451c07271940016cec6f5ad8a155263b
PKG_TARGETS:=bin
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
include $(INCLUDE_DIR)/package.mk
define uboot/Default