aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-09-10 16:57:20 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-09-10 16:57:20 +0000
commitcce178857148137e3ef8b2d188b7dda1e989c4d0 (patch)
treec40f182ac225c0cb81021d1b752cf67ae6f886ab /package
parent7995ee3af06028d677f614cc251d136562272ddb (diff)
downloadmaster-187ad058-cce178857148137e3ef8b2d188b7dda1e989c4d0.tar.gz
master-187ad058-cce178857148137e3ef8b2d188b7dda1e989c4d0.tar.bz2
master-187ad058-cce178857148137e3ef8b2d188b7dda1e989c4d0.zip
fix the broken build for brcm 2.4, idea from nbd
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1887 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/Makefile1
-rw-r--r--package/nvram/Makefile4
2 files changed, 2 insertions, 3 deletions
diff --git a/package/Makefile b/package/Makefile
index cdc592bdde..86a84a4755 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -372,6 +372,7 @@ $(STAMP_DIR):
TARGET_DIR="$(TARGET_DIR)" \
IPKG_CONF="$(IPKG_CONF)" \
BOARD="$(BOARD)" \
+ KERNEL="$(KERNEL)" \
install
%-rebuild:
diff --git a/package/nvram/Makefile b/package/nvram/Makefile
index 337f722b51..f7312fe18b 100644
--- a/package/nvram/Makefile
+++ b/package/nvram/Makefile
@@ -10,13 +10,11 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
include $(TOPDIR)/package/rules.mk
# does not depend on menuconfig
-ifneq ($(BOARD),brcm)
+ifneq ($(BOARD)-$(KERNEL),brcm-2.4)
BR2_PACKAGE_NVRAM:=m
else
-ifeq ($(LINUX_VERSION),2.4.30)
BR2_PACKAGE_NVRAM:=y
endif
-endif
$(eval $(call PKG_template,NVRAM,nvram,$(PKG_RELEASE),$(ARCH)))