aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-03-07 12:59:19 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-03-07 12:59:19 +0000
commitc5b1e5ded29e0054b02fc8cfb6617a07b7fd90f5 (patch)
treebef3e5322b3ab1c3ec76585d3e2fc0b5127686a4 /package
parentf5b3b05ba88d57155b87470c203a50be494dd334 (diff)
downloadmaster-187ad058-c5b1e5ded29e0054b02fc8cfb6617a07b7fd90f5.tar.gz
master-187ad058-c5b1e5ded29e0054b02fc8cfb6617a07b7fd90f5.tar.bz2
master-187ad058-c5b1e5ded29e0054b02fc8cfb6617a07b7fd90f5.zip
only support EABI on ARM targets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25928 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/apex/Makefile5
-rw-r--r--package/madwifi/Makefile12
2 files changed, 8 insertions, 9 deletions
diff --git a/package/apex/Makefile b/package/apex/Makefile
index 97ddee18d8..f17118e46c 100644
--- a/package/apex/Makefile
+++ b/package/apex/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -34,7 +34,6 @@ define build_apex
$(MAKE) -C $(PKG_BUILD_DIR) \
ARCH=arm \
$(1)_config
- $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(PKG_BUILD_DIR)/.config
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
KBUILD_HAVE_NLS=no \
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 5b0342a53b..6350a18052 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -74,25 +74,25 @@ ifeq ($(ARCH),i686)
HAL_TARGET:=i386-elf
endif
ifeq ($(BOARD),ixp4xx)
- HAL_TARGET:=xscale-be-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
+ HAL_TARGET:=xscale-be-elfgnueabi
endif
ifeq ($(BOARD),iop32x)
- HAL_TARGET:=xscale-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
+ HAL_TARGET:=xscale-le-elfgnueabi
endif
ifeq ($(BOARD),kirkwood)
- HAL_TARGET:=xscale-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
+ HAL_TARGET:=xscale-le-elfgnueabi
endif
ifeq ($(BOARD),orion)
- HAL_TARGET:=xscale-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
+ HAL_TARGET:=xscale-le-elfgnueabi
endif
ifeq ($(BOARD),cns3xxx)
- HAL_TARGET:=arm11-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
+ HAL_TARGET:=arm11-le-elfgnueabi
endif
ifeq ($(ARCH),powerpc)
HAL_TARGET:=powerpc-be-elf
endif
ifeq ($(BOARD),gemini)
- HAL_TARGET:=armv4-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
+ HAL_TARGET:=armv4-le-elfgnueabi
endif
ifneq ($(CONFIG_TARGET_atheros),)
HAL_TARGET:=wisoc