aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-10-29 15:02:38 +0000
committerJohn Crispin <blogic@openwrt.org>2014-10-29 15:02:38 +0000
commitbaaf2ce055b71a529e54b1ff66169a7fc5b9a54d (patch)
tree25254e5a5b7f02c76bb219362e7a775dd4a6ab88 /package
parent1968a036e6394688dc4a76d5569ba69adf5bd0c3 (diff)
downloadmaster-187ad058-baaf2ce055b71a529e54b1ff66169a7fc5b9a54d.tar.gz
master-187ad058-baaf2ce055b71a529e54b1ff66169a7fc5b9a54d.tar.bz2
master-187ad058-baaf2ce055b71a529e54b1ff66169a7fc5b9a54d.zip
Add support for DHT11 driver
The DHT11 is a temperature and humidity sensor supported by linux since 3.14. This patch is tested on recent mxs with kernel 3.14.18. Signed-off-by: Harald Geyer <harald@ccbib.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43103 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 58aae3ce58..c514fd7366 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -258,6 +258,26 @@ endef
$(eval $(call KernelPackage,iio-ad799x))
+
+define KernelPackage/iio-dht11
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=kmod-iio-core @GPIO_SUPPORT @USES_DEVICETREE
+ TITLE:=DHT11 (and compatible) humidity and temperature sensors
+ KCONFIG:= \
+ CONFIG_DHT11
+ FILES:=$(LINUX_DIR)/drivers/iio/humidity/dht11.ko
+ AUTOLOAD:=$(call AutoLoad,56,dht11)
+endef
+
+define KernelPackage/iio-dht11/description
+ support for DHT11 and DHT22 digitial humidity and temperature sensors
+ attached at GPIO lines. You will need a custom device tree file to
+ specify the GPIO line to use.
+endef
+
+$(eval $(call KernelPackage,iio-dht11))
+
+
define KernelPackage/lp
SUBMENU:=$(OTHER_MENU)
TITLE:=Parallel port and line printer support