aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2013-07-17 22:49:16 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2013-07-17 22:49:16 +0000
commitb476b188506664176b010366e05131156ab02f66 (patch)
tree530d60ad33d6820ff8f21576493d74d33b416552 /package
parent3fdbe277fad54c44d2f6e353ffe4043400c55d61 (diff)
downloadmaster-187ad058-b476b188506664176b010366e05131156ab02f66.tar.gz
master-187ad058-b476b188506664176b010366e05131156ab02f66.tar.bz2
master-187ad058-b476b188506664176b010366e05131156ab02f66.zip
imx23: ChipIdea changes
- move ci_hdrc into generic modules - add separate package for imx-specific modules Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37384 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 0fa99ccb79..10c82803d7 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1023,3 +1023,22 @@ $(call KernelPackage/usbip/Default)
$(call AddDepends/usb)
endef
$(eval $(call KernelPackage,usbip-server))
+
+define KernelPackage/usb-chipidea
+ TITLE:=Support for ChipIdea controllers
+ KCONFIG:= \
+ CONFIG_USB_CHIPIDEA \
+ CONFIG_USB_CHIPIDEA_HOST=y \
+ CONFIG_USB_CHIPIDEA_DEBUG=y
+ FILES:=\
+ $(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc.ko
+ AUTOLOAD:=$(call AutoLoad,51,ci_hdrc,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-chipidea/description
+ Kernel support for USB ChipIdea controllers
+endef
+
+$(eval $(call KernelPackage,usb-chipidea,1))
+