aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-05-23 13:07:44 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-05-23 13:07:44 +0000
commitab98ef05fc4e577aa5e535695bbd5494133f0a4e (patch)
tree1b953e60a2a03eb693fee560bc45931544b0f3a8 /package
parent8e6bff8bef934736944193476f1824cea0e8475c (diff)
downloadmaster-187ad058-ab98ef05fc4e577aa5e535695bbd5494133f0a4e.tar.gz
master-187ad058-ab98ef05fc4e577aa5e535695bbd5494133f0a4e.tar.bz2
master-187ad058-ab98ef05fc4e577aa5e535695bbd5494133f0a4e.zip
firewall3: update to git head
- Use weak references for instantiating libext*.a matches, makes fw3 independant from the compile time features of iptables - Do not leak memory when processing rules with unknown targets or matches git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36698 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/network/config/firewall3/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/config/firewall3/Makefile b/package/network/config/firewall3/Makefile
index 73941dae2f..1ec8ae651d 100644
--- a/package/network/config/firewall3/Makefile
+++ b/package/network/config/firewall3/Makefile
@@ -14,7 +14,7 @@ PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/firewall3.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=c3a5b984f6cec4014c1120ee900a53b452eb9e32
+PKG_SOURCE_VERSION:=a93d95470803e9026c725fc7081ac8a06191ea6a
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
@@ -47,7 +47,7 @@ define Build/Compile
endef
TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_LDFLAGS += -Wl,--gc-sections -Wl,--whole-archive
define Package/firewall3/install
$(INSTALL_DIR) $(1)/sbin