aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2013-06-18 12:51:14 +0000
committerSteven Barth <steven@midlink.org>2013-06-18 12:51:14 +0000
commita84a14bb3b283338974cb3df5404d78138586f19 (patch)
tree20066740ec481b846bb6c72f3b3a52b52bfa8b6c /package
parentfcf2609605b3a3aaadc598152eab03340617d259 (diff)
downloadmaster-187ad058-a84a14bb3b283338974cb3df5404d78138586f19.tar.gz
master-187ad058-a84a14bb3b283338974cb3df5404d78138586f19.tar.bz2
master-187ad058-a84a14bb3b283338974cb3df5404d78138586f19.zip
odhcp6c: Add option to override interface identifier in RA-client
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36959 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile4
-rwxr-xr-xpackage/network/ipv6/odhcp6c/files/dhcpv6.sh6
2 files changed, 6 insertions, 4 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index 125dea8409..9d39fdfa37 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-06-13
+PKG_VERSION:=2013-06-18
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=83114b179091cb080f09cf4142ee1c9949ea4e30
+PKG_SOURCE_VERSION:=eaf3a11cad8a5dd389d5f52cc76e424e0242074b
PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/odhcp6c/files/dhcpv6.sh b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
index b2264ed907..c5e77c65b4 100755
--- a/package/network/ipv6/odhcp6c/files/dhcpv6.sh
+++ b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
@@ -18,8 +18,8 @@ proto_dhcpv6_setup() {
local config="$1"
local iface="$2"
- local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite
- json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite
+ local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
+ json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
# Configure
@@ -35,6 +35,8 @@ proto_dhcpv6_setup() {
[ "$norelease" = "1" ] && append opts "-k"
+ [ -n "$ifaceid" ] && append opts "-i$ifaceid"
+
for opt in $reqopts; do
append opts "-r$opt"
done