aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-11-17 09:40:06 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-11-17 09:40:06 +0000
commit8fc48ae271ed4a47f1c336168dc504e8b0980f3a (patch)
tree79469742d04f3855467cdf69432f96fc7392001b /package
parent0e9b267b5c2fdf79ac9627c05a2460ee36224e92 (diff)
downloadmaster-187ad058-8fc48ae271ed4a47f1c336168dc504e8b0980f3a.tar.gz
master-187ad058-8fc48ae271ed4a47f1c336168dc504e8b0980f3a.tar.bz2
master-187ad058-8fc48ae271ed4a47f1c336168dc504e8b0980f3a.zip
[package] base-files: another empty password check fix (#10440)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29208 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/bin/login.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index b93d2cb402..9b3745ba98 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=96
+PKG_RELEASE:=97
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/bin/login.sh b/package/base-files/files/bin/login.sh
index 6682b022ba..04b3fe2502 100755
--- a/package/base-files/files/bin/login.sh
+++ b/package/base-files/files/bin/login.sh
@@ -1,7 +1,7 @@
#!/bin/sh
# Copyright (C) 2006-2011 OpenWrt.org
-if ( ! grep -qs '^root::' /etc/shadow || \
+if ( ! grep -qs '^root:[!x]\?:' /etc/shadow || \
! grep -qs '^root:[!x]\?:' /etc/passwd ) && \
[ -z "$FAILSAFE" ]
then