aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2007-09-10 21:19:21 +0000
committerJohn Crispin <blogic@openwrt.org>2007-09-10 21:19:21 +0000
commit88420c0891db40dc1aa8dccb3a54cac4e63c0f35 (patch)
tree6038d17f1b97dba34f0c2536a177e769679c5bb1 /package
parentee511ef3605e9cef7da20e7e43a9b94a9ce1a00a (diff)
downloadmaster-187ad058-88420c0891db40dc1aa8dccb3a54cac4e63c0f35.tar.gz
master-187ad058-88420c0891db40dc1aa8dccb3a54cac4e63c0f35.tar.bz2
master-187ad058-88420c0891db40dc1aa8dccb3a54cac4e63c0f35.zip
added a init.d script to fonera-mp3d
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8734 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/fonera-mp3/Makefile2
-rw-r--r--package/fonera-mp3/files/mp3d.init12
2 files changed, 14 insertions, 0 deletions
diff --git a/package/fonera-mp3/Makefile b/package/fonera-mp3/Makefile
index d7431ff4d0..1cdbd4c51c 100644
--- a/package/fonera-mp3/Makefile
+++ b/package/fonera-mp3/Makefile
@@ -57,6 +57,8 @@ define Package/fonera-mp3d/install
ln -sf mp3.cgi $(1)/www/cgi-bin/mp3_remote.cgi
$(INSTALL_DIR) $(1)/www/local
$(INSTALL_DATA) $(PKG_BUILD_DIR)/cgi/{stylesheet.css,json.js} $(1)/www/local/
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/mp3d.init $(1)/etc/init.d/mp3d
endef
$(eval $(call BuildPackage,fonera-mp3d))
diff --git a/package/fonera-mp3/files/mp3d.init b/package/fonera-mp3/files/mp3d.init
new file mode 100644
index 0000000000..9935a064de
--- /dev/null
+++ b/package/fonera-mp3/files/mp3d.init
@@ -0,0 +1,12 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2007 OpenWrt.org
+
+START=90
+
+start() {
+ /usr/bin/mp3d
+}
+
+stop() {
+ killall mp3d
+}