aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-29 15:08:23 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-29 15:08:23 +0000
commit7c56aea1c1c4118ffe615ceebd8adce1be841071 (patch)
tree45376d7276d3ce52f494610465b8dc315709d4b7 /package
parent223e587e8388fcb0391efe3cb7a74e3c3f8d7da1 (diff)
downloadmaster-187ad058-7c56aea1c1c4118ffe615ceebd8adce1be841071.tar.gz
master-187ad058-7c56aea1c1c4118ffe615ceebd8adce1be841071.tar.bz2
master-187ad058-7c56aea1c1c4118ffe615ceebd8adce1be841071.zip
package/kernel: add module for the Pericom PT7C4338 RTC chip
Signed-off-by: Wojciech Dubowik <Wojciech.Dubowik@neratec.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31526 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index d6eab58704..0a467f92fd 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -828,6 +828,20 @@ endef
$(eval $(call KernelPackage,rtc-pcf2123))
+define KernelPackage/rtc-pt7c4338
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Pericom PT7C4338 RTC support
+ $(call AddDepends/rtc,+kmod-i2c-core)
+ KCONFIG:=CONFIG_RTC_DRV_PT7C4338
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pt7c4338.ko
+ AUTOLOAD:=$(call AutoLoad,60,rtc-pt7c4338)
+endef
+
+define KernelPackage/rtc-pt7c4338/description
+ Kernel module for Pericom PT7C4338 i2c RTC chip.
+endef
+
+$(eval $(call KernelPackage,rtc-pt7c4338))
define KernelPackage/n810bm
SUBMENU:=$(OTHER_MENU)