aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-06-03 13:59:14 +0000
committerJohn Crispin <blogic@openwrt.org>2015-06-03 13:59:14 +0000
commit722c9b412ef072f10ef69a212485dcd92288583d (patch)
tree8a1807b4abbc43ac7b8d85ce985cda2ca8881dec /package
parentb224fbdca6c23630f6cf0edcca8d04ccc5219195 (diff)
downloadmaster-187ad058-722c9b412ef072f10ef69a212485dcd92288583d.tar.gz
master-187ad058-722c9b412ef072f10ef69a212485dcd92288583d.tar.bz2
master-187ad058-722c9b412ef072f10ef69a212485dcd92288583d.zip
lldpd: add option to disable custom TLVs
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45884 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/network/services/lldpd/Config.in5
-rw-r--r--package/network/services/lldpd/Makefile1
2 files changed, 6 insertions, 0 deletions
diff --git a/package/network/services/lldpd/Config.in b/package/network/services/lldpd/Config.in
index 448506d047..93d84e29ea 100644
--- a/package/network/services/lldpd/Config.in
+++ b/package/network/services/lldpd/Config.in
@@ -41,6 +41,11 @@ config LLDPD_WITH_DOT3
prompt "Enable Dot3 extension (PHY stuff)"
default y
+config LLDPD_WITH_CUSTOM
+ bool
+ prompt "Enable Custom TLVs"
+ default y
+
config LLDPD_WITH_JSON
bool
prompt "Enable JSON output for the LLDP Command-Line Interface"
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index cccb9ba5d7..81e4a8ffb0 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -100,6 +100,7 @@ CONFIGURE_ARGS += \
$(if $(CONFIG_LLDPD_WITH_LLDPMED),,--disable-lldpmed) \
$(if $(CONFIG_LLDPD_WITH_DOT1),,--disable-dot1) \
$(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
+ $(if $(CONFIG_LLDPD_WITH_CUSTOM),,--disable-custom) \
$(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
$(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c,--with-json=no)