aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-06 16:10:20 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-06 16:10:20 +0000
commit6c02192400a6b3d00750c4fcdce2f1b532c0c9f1 (patch)
treec9ddbbbdbd7f63b19fb2600bf7724f41aabc9599 /package
parent0c6b1278e49c66c2374b4643ad72da7915055fe7 (diff)
downloadmaster-187ad058-6c02192400a6b3d00750c4fcdce2f1b532c0c9f1.tar.gz
master-187ad058-6c02192400a6b3d00750c4fcdce2f1b532c0c9f1.tar.bz2
master-187ad058-6c02192400a6b3d00750c4fcdce2f1b532c0c9f1.zip
Add the gpio_keys input module to menuconfig
Signed-off-by: Ferenc Wagner <wferi@niif.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16716 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 74905e1234..fdadfa10e1 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -674,6 +674,23 @@ endef
$(eval $(call KernelPackage,input-polldev))
+define KernelPackage/input-gpio-keys
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=GPIO key support
+ DEPENDS:= @GPIO_SUPPORT +kmod-input-core
+ KCONFIG:=CONFIG_KEYBOARD_GPIO
+ FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,60,gpio_keys)
+endef
+
+define KernelPackage/input-gpio-keys/description
+ This driver implements support for buttons connected
+ to GPIO pins of various CPUs (and some other chips).
+endef
+
+$(eval $(call KernelPackage,input-gpio-keys))
+
+
define KernelPackage/input-gpio-buttons
SUBMENU:=$(OTHER_MENU)
TITLE:=Polled GPIO buttons input device